发布于 2018-02-13 14:27:53 | 33 次阅读 | 评论: 0 | 来源: 网友投递

这里有新鲜出炉的Swift教程,程序狗速度看过来!

Swift编程语言

SWIFT,苹果于2014年WWDC(苹果开发者大会)发布的新开发语言,可与Objective-C*共同运行于Mac OS和iOS平台,用于搭建基于苹果平台的应用程序。


这篇文章主要给大家介绍了关于在Swift 4.0中如何引用3.0第三方库的相关资料,文中通过图文介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友们下面随着小编来一起学习学习吧。

前言

第三方库是所有工程师在开发中都会经常用到的,熟练的掌握多个第三方库能把我们的生产力提升一大截,Swift 已经发布了 4.0 版本,在 Xcode9 中新建项目后,默认是使用 4.0 语法的。项目中的引用的第三方库,虽然有很多已经发不了 4.0 版本,但是还是有一些未及时更新的,那在作者未更新之前我们是否有更好的办法来使用这些第三方库呢?

答案当然是 肯定 的, Xcode9 中是同时支持 3.2 和 4.0 语法的。

具体的设置可以看下图。


那么下面就说说如何设置同时支持 3.2 和 4.0 。

项目中如果使用 Cocoapods 来管理第三方库时,可以找到不支持 4.0 语法的库所在 target ,然后找到 Swift Language Version 选项,改为 3.2 ,然后就可以顺利编译通过了。


如果还有以源码集成进项目的,那就选择 Edit > Convert > To Current Swift Syntax.. 吧

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,如果有疑问大家可以留言交流,谢谢大家对PHPERZ的支持。



相关阅读 :
Swift 4.0中如何引用3.0的第三方库
升级到Swift 4.0可能遇到的坑总结
程序迁移到swift 3.0的一些实用技巧
Swift中如何避免循环引用的方法
详谈swift内存管理中的引用计数
Swift在扩展中添加协议成员
Swift难点-继承中的构造规则实例详解
swift读取字典中最大的数组和数组最大值
深入解析Swift语言编程中的可选链
浅谈Swift编程中switch与fallthrough语句的使用
Swift中使用正则表达式的一些方法
Swift在控件中添加点击手势的方法
最新网友评论  共有(0)条评论 发布评论 返回顶部
月排行榜

Copyright © 2007-2017 PHPERZ.COM All Rights Reserved   冀ICP备14009818号  版权声明  广告服务