发布于 2017-10-16 05:48:36 | 86 次阅读 | 评论: 0 | 来源: 网友投递

这里有新鲜出炉的精品教程,程序狗速度看过来!

Ubuntu Linux操作系统

Ubuntu(乌班图)是一个以桌面应用为主的Linux操作系统。Ubuntu基于Debian发行版和GNOME桌面环境,与Debian的不同在于它每6个月会发布一个新版本。


这篇文章主要介绍了ubuntu16.04下安装openssh-server报依赖错误的完美解决方法(非常不错)的相关资料,需要的朋友可以参考下

问题:系统重装后,安装和配置SSH,防火墙配置


#安装install openssh-server
sudo apt install openssh-server -y

遇到问题:


sudo apt install openssh-server -y

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是

因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件

包尚未被创建或是它们已被从新到(Incoming)目录移出。

下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:


openssh-server : 依赖: openssh-client (= 1:7.1p1-4)

依赖: openssh-sftp-server 但是它将不会被安装

推荐: ssh-import-id 但是它将不会被安装

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

解决方法:

ubuntu自带的有openssh-client,所以可以通过

ssh username@host

来远程连接linux

可是要想通过ssh被连接,ubuntu系统需要有openssh-server,可以通过


ps -e | grep ssh

来查看,如果没有显示sshd则说明没有安装openssh-server

可通过


sudo apt-get install openssh-server

来安装openssh-server,如果顺利的话会安装成功,如果遇到


$ sudo apt install openssh-server -y

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是

因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件

包尚未被创建或是它们已被从新到(Incoming)目录移出。

下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:

openssh-server : 依赖: openssh-client (= 1:7.1p1-4)

依赖: openssh-sftp-server 但是它将不会被安装

推荐: ssh-import-id 但是它将不会被安装

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

这是因为,openssh-server是依赖于openssh-clien的,那ubuntu不是自带了openssh-client吗?原由是自带的openssh-clien与所要安装的openssh-server所依赖的版本不同,这里所依赖的版本是

1:7.1p1-4

所以要安装对应版本的openssh-clien,来覆盖掉ubuntu自带的

PS:下面看下ubuntu无法安装openssh-server的解决方法

使用ubuntu安装的命令


sudo apt-get install openssh-server

出现如下的错误

现在没有可用的软件包 openssh-server,但是它被其它的软件包引用了.

这可能意味着这个缺失的软件包可能已被废弃,或者只能在劳动保险发布源中找到.

E:软件包openssh-server还没有可供安装的候选者

解决方法

命令:


sudo apt-get update

之后用如下命令下载openssh-server

命令:


sudo apt-get install openssh-server

这样就OK

检查ssh服务开启状态


ps -s | grep ssh
#启用ssh的指令
启动ssh服务:
#sudo /etc/init.d/ssh start
停止ssh服务:
#sudo /etc/init.d/ssh stop
重启ssh服务:
#sudo /etc/init.d/ssh restart

以上所述是小编给大家介绍的ubuntu16.04下安装openssh-server报依赖错误的完美解决方法(非常不错),希望对大家有所帮助,如果大家有任何疑问欢迎给我留言,小编会及时回复大家的!



相关阅读 :
ubuntu16.04下安装openssh-server报依赖错误的完美解决方法(非常不错)
Ubuntu 16.04下无法安装.deb的解决方法
ubuntu下安装软件Could not get lock /var/lib/dpkg/lock错误解决方法
Ubuntu 16.04安装搜狗拼音输入法错误问题的解决方法
Ubuntu系统下安装ImageMagick出错的解决过程
Ubuntu访问window下的磁盘分区出现“Error mounting /dev/sda5 at/media”错误的解决方法
ubuntu14.04 使用中遇到的问题及解决方法集锦
Ubuntu安装telent服务器时出现:apt-get:Package has no installation的原因及解决方法
ubuntu下kvm 命令行安装64位ubuntu报"Couldn't find hvm kernel for Ubuntu tree."的问题分析
解决 Ubuntu 开机 Waiting for 60 seconds more for network configuration
最新网友评论  共有(0)条评论 发布评论 返回顶部

Copyright © 2007-2017 PHPERZ.COM All Rights Reserved   冀ICP备14009818号  版权声明  广告服务